Joomla: poruka „Database Error: Unable to connect to the database:Could not connect to MySQL”
Joomla koristi bazu podataka. Ako se iz nekog razloga ne uspije povezati s bazom podataka, može se prikazati ova poruka:
Database Error: Unable to connect to the database:Could not connect to MySQL
U datoteci configuration.php (nalazi se u mapi u kojoj je Joomla instalirana) nalaze se ove postavke za povezivanje s bazom podataka:
var $host = 'localhost'; // Ovo je uvijek localhost
var $user = 'XXX_ZZZ'; // Na mjestu XXX nalazi se ime korisnika upravljačke ploče, na mjestu ZZZ korisnik baze podataka
var $db = 'XXX_YYY'; // Na mjestu XXX nalazi se ime korisnika upravljačke ploče, na mjestu YYY naziv baze podataka
var $password = 'lozinka'; // Lozinka koju ste dodijelili korisniku baze podataka
Ako se ne možete povezati, možda nešto nije u redu s gornjim podacima.
Prijavite se u upravljačku ploču i odaberite izbornik MySQL. Zatim odaberite bazu podataka Joomle (kliknite je) i ondje se prikazuju postojeći korisnici baze podataka. Po potrebi izradite novog korisnika baze podataka te to korisničko ime i lozinku unesite u configuration.php. Ako korisnik baze podataka već postoji, za svaki slučaj promijenite lozinku kako bi odgovarala onoj u configuration.php.
Ako ste Joomlu instalirali putem Installatrona, naziv baze podataka možete saznati i putem Installatrona.
