Joomla: Database Error: Unable to connect to the database:Could not connect to MySQL
Joomla verwendet eine Datenbank. Wenn aus irgendeinem Grund keine Verbindung zur Datenbank zustande kommt, erhalten Sie möglicherweise diese Meldung:
Database Error: Unable to connect to the database:Could not connect to MySQL
In der Datei configuration.php (im Ordner, in dem Joomla installiert ist) finden Sie diese Einstellungen für die Verbindung zur Datenbank:
var $host = 'localhost'; // Das ist immer localhost
var $user = 'XXX_ZZZ'; // XXX ist der Benutzername des Control Panels, ZZZ der Datenbankbenutzer
var $db = 'XXX_YYY'; // XXX ist der Benutzername des Control Panels, YYY der Name der Datenbank
var $password = 'wachtwoord'; // Das Passwort, das Sie dem Datenbankbenutzer zugewiesen haben
Wenn keine Verbindung möglich ist, stimmt mit diesen Angaben vermutlich etwas nicht.
Melden Sie sich im Control Panel an und wählen Sie das Menü MySQL. Klicken Sie dann auf die Joomla-Datenbank; dort werden die vorhandenen Datenbankbenutzer angezeigt. Legen Sie bei Bedarf einen neuen Datenbankbenutzer an und tragen Sie dessen Benutzernamen und Passwort in die configuration.php ein. Gibt es den Datenbankbenutzer bereits, ändern Sie zur Sicherheit sein Passwort, damit es mit der configuration.php übereinstimmt.
Haben Sie Joomla über Installatron installiert, können Sie den Namen der Datenbank übrigens auch über Installatron herausfinden.
